Athens-v14-upgrade
Incident Report for ZetaChain
Resolved
Testnet is producing blocks again.
Posted Mar 03, 2024 - 01:11 UTC
Investigating
We're currently investigating the issue. Currently the network needs more validators to start with the v14 to begin processing blocks again.
Posted Mar 02, 2024 - 23:40 UTC
This incident affected: Athens Testnet.