ZetaChain

ZetaScan is not showing latest blocks on testnet
Resolved

The explorer is now displaying the latest produced blocks.

Wed, May 15, 2024, 12:41 PM
(1 year ago)
·
Affected components

No components marked as affected

Updates

Resolved

The explorer is now displaying the latest produced blocks.

Wed, May 15, 2024, 12:41 PM

Investigating

We think the impact from the issue is over.

Wed, May 15, 2024, 12:39 PM

Investigating

We are currently investigating this issue.

Wed, May 15, 2024, 06:31 AM(6 hours earlier)
Powered by