ZetaChain

Athens Testnet: BTC Testnet3 block storm
Resolved

The BTC Testnet3 network has returned to normal.

Tue, Aug 27, 2024, 03:47 AM
(8 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

The BTC Testnet3 network has returned to normal.

Tue, Aug 27, 2024, 03:47 AM

Identified

The Athens Testnet is currently behind in processing BTC blocks due to a BTC block storm.

Mon, Aug 26, 2024, 03:53 PM(11 hours earlier)
Powered by