Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 20, 2024 - 17:30 UTC
Update
A new ZetaChain ERC-20 Custody contract for Polygon is being deployed and all funds will be migrated from the old contract to the new one. The original contract will be paused during the migration and will revert all transactions.
After the migration, your dapp must use the new ERC-20 Custody contract address at 0x0Bad40D9e9C369f2223c835E108f43a45fd223B5. The contract interface remains the same so no changes other than the contract address are needed.
Transaction on the ZetaChain EVM will continue to operate normally. Only transactions involving the ERC-20 Custody Contract on Polygon will be reverted during this maintenance window.
How to Upgrade to the new ERC-20 Custody Contract Address:
If you have hardcoded the address anywhere in your dapp you'll need to make the change manually at the correct time for each external chain. See Status.ZetaChain.com for the specific maintenance window for each connected chain.
If your dapp queries the address dynamically from the `/zeta-chain/observer/get_chain_params` endpoint then your dapp will pickup the change automatically and no action is needed.
If you use the Protocol-Contracts NPM Package you will need to update to the latest version during the maintenance window.
Posted Nov 20, 2024 - 17:00 UTC
Scheduled
A new ZetaChain ERC-20 Custody contract for Polygon is being deployed and all funds will be migrated from the old contract to the new one. The original contract will be paused during the migration and will revert all transactions.
After the migration, your dapp must use the new ERC-20 Custody contract address at 0x0Bad40D9e9C369f2223c835E108f43a45fd223B5. The contract interface remains the same so no changes other than the contract address are needed.
Transaction on the ZetaChain EVM will continue to operate normally. Only transactions involving the ERC-20 Custody Contract on Polygon will be reverted during this maintenance window.
How to Upgrade to the new ERC-20 Custody Contract Address:
If you have hardcoded the address anywhere in your dapp you'll need to make the change manually at the correct time for each external chain. See Status.ZetaChain.com for the specific maintenance window for each connected chain.
If your dapp queries the address dynamically from the `/zeta-chain/observer/get_chain_params` endpoint then your dapp will pickup the change automatically and no action is needed.
If you use the Protocol-Contracts NPM Package you will need to update to the latest version during the maintenance window.