No components marked as affected
Resolved
Thank you to all node operators. The v28 upgrade has activated successfully.
Identified
To protect against a high criticality security update, ZetaChain has released governance proposals 90 on testnet (https://testnet.ping.pub/zetachain/gov/90) and 51 on mainnet (https://ping.pub/zetachain/gov/51) to upgrade the networks to v28 on Feb 21st 2025 ~3pm PST and Feb 24 2025 ~9am PST respectively. We request that all validators vote on the proposals, and prepare to accomplish the upgrade.
The only change being made is an update from Cosmos SDK v0.50.11 -> v0.50.12. For more information on the CosmosSDK vulnerability, please see their security advisory here: ASA-2025-003: Groups module can halt chain when handling a malicious proposal
Additional Critical Information:
Due to the low difficulty required to exploit this vulnerability, please monitor this page for updates if the chain halts prior to the upgrade height.
If the chain does halt earlier than planned, please install the v28 binary ASAP.
A chain halt is possible but no funds are at risk.
Additional Technical Notes:• Validators using Cosmovisor are encouraged to pre-download the correct binary to their upgrades/v28/bin directory• Monitor the upgrade status in your validator logs• Join the our nodes-general discord channel for real-time support during the upgrade
For additional support or questions, please contact the technical team through our official channels.