ZetaChain

ZetaChain Testnet Outage
Resolved·Full outage

After several days of observation, the Testnet has proven to be stable and reliable.

Thu, Aug 21, 2025, 08:32 PM
(1 week ago)
·
Affected components
Updates

Resolved

After several days of observation, the Testnet has proven to be stable and reliable.

Thu, Aug 21, 2025, 08:32 PM

Monitoring

The scheduled v33 upgrade on Testnet was executed at block 12060000.

Validators successfully completed the upgrade and resumed block production after migrations were applied (~5 minutes).

Post-upgrade, several issues were observed:

  • RPC node failures due to consensus state divergence caused by a SUI gas ZRC20 migration inconsistency. Some RPCs required resync from fresh snapshots.

  • Startup errors for operators related to minimum-gas-prices configuration in app.toml. Sharing updated configs and snapshots resolved most cases.

  • Trace RPC errors (debug_traceBlockByNumber) now affecting all tested blocks, likely due to proto definition changes; a fix is in progress.

  • Legacy proposal query failures (/cosmos/gov/v1/proposals) caused by removed Ethermint types; temporary workarounds are in place while codec updates are prepared.

The network is producing blocks and majority of services are operational. We continue to monitor and apply fixes for remaining RPC trace and configuration issues.

Wed, Aug 13, 2025, 01:02 AM(1 week earlier)

Investigating

Our validators have begun producing blocks.

Tue, Aug 12, 2025, 06:08 PM(6 hours earlier)

Investigating

We are looking into issues with the V33 Software Upgrade being rolled out on ZetaChain Testnet. Some RPCs and 3rd party operators are unable to complete the upgrade.

Tue, Aug 12, 2025, 06:06 PM
Powered by